This page has been moved to /plugins-reference/plugins-creation-prerequisites/